$totlines when printing

Author: ville.lahdensuo@ladok.umu.se (Ville58)

Hello everybody,

I have countered a problem when printing.

I’m getting different $totlines. If I choose PDF-creator, I get $totlines = 79, but with our default printer $totlines are 76. This difference is causing problems when printing (one page with PDF-creator becomes two when using default printer).

I guess that this has something to do with printer settings. My questions are:

- How does Uniface decide $totlines when I have chosen the printer?

- Is there some way for me to change printer settings so that $totlines would be the same?

I hope there is someone out there who can help me.

Best regards,

 Ville Lahdensuo

 Ladok Division, Umeå University

2 Comments

  1. Hi Ville,

    Just enter in your PRATT different bottom margins to balance the difference.

    if you use P_MSWIN3 or P_MSWINX,
    uniface communicates with the selected Windows printer driver to get the settings.

    Sometimes, you have different settings in the border sizes and this causes different $totlines.
    Sometimes, the available fonts can differ and the substitution font is smaller/larger on one of the devices.

    Success, Uli

     


    Author: ulrich-merkel (ulrichmerkel@web.de)
  2. Thank you Uli.

    I believe that different printer settings are causing my problem. Different bottom margins are, as you wrote, the way to solve the problem.

    Thank you once again.

    /Ville


    Author: Ville58 (ville.lahdensuo@ladok.umu.se)