java requirement for Uniface 7.2

Author: nic.writes@gmail.com (nicola)

Hi all,

We have an application running on HP-UX 10.20 that is using Uniface 7.2. We are upgrading java to 1.6.  I want to know if uniface is effected by this java upgrade. What is the basic requirement of java for Uniface 7.2.

Any suggestion or pointers of where to find more information will also be very helpful. Kindly excuse my ignorance.

- Thanks in advance :)

 

3 Comments

  1. Hi all,

    ANY information or pointer on this will be very helpful. Even an requirement document for Uniface 7.2 will do. Please assist.

    -Nicola


    Author: nicola (nic.writes@gmail.com)
  2. Hi nicola,

    sorry for letting you wait so long for an answer:

    The standard uniface 7.2 has no dependencies with JAVA at all.

    HTH, Uli


    Author: ulrich-merkel (ulrichmerkel@web.de)
  3. Hi Nicola,

    Are you using Uniface WRD, or java callin/callout? If not, you don't have to worry about the Java version.

    For the java callin/out I'm trying to dig up the information, but I'm not sure whether I still have it available. For the WRD there should be no problem in upgrading to a newer Java, since the WRD is a well-programmed standard servlet with some custom socket implementation for the connection to the WASV (also compatible java code).

    Of course, if you migrate your environment a thorough test is needed if you are using one of the abovementioned items.

    Regards,

    Sjoerd (IctCoreBiz)


    Author: sbakker (uniface@ictcore.biz)