Checking whether a string contain Font 0 characters only

Author: a.widdowson@midlandhr.co.uk (awiddowson)

I am trying to fix a problem whereby a Uniface component reads from a entity mapped to an ldap driver. The ldap data contains a name with letters that are not in font 0 (we are using LATIN1 as characterset) which is causing problems when storing the data onto the Oracle database (Error 0131 font not valid message is produced). So I am trying to test the string to see if any non ascii characters in it. Have tried using a syntax string (if field='?' on each character) but this is not working. Going through the characters in the string one by one, one of them is set to $?. Is there a better way to detect for non font 0 characters in a string. This application is Uniface 7.

2 Comments

  1. Hi Anthony, can you define the syntax of the field as "ASC" which is ASCII only and use fieldcheck after reading the data? Or compare the whole string against a syntax string: if (v_mystring = '?*') ... endif Success, Uli


    Author: ulrich-merkel (ulrichmerkel@web.de)
  2. I tried using a syntax string but it did not work properly with the non font 0 characters. I've managed to get it to work now but checking that each character in the string is less than or equal to ? which is the last character in font0 - this will suffice for what our application needs


    Author: awiddowson (a.widdowson@midlandhr.co.uk)