License Types

Author: norbert.lauterbach@infraserv.com (Lauterbach)

Is there a Special License requiered for using the Debugger with Uniface 10? If program reaches the Statement "debug" I get an "8011 License not available" and no Debugger is opening! What License Types exist? And for what are they used? Kind regards Norbert

12 Comments

  1. Thanks Ingo and Daniel for these useful suggestions. I will certainly use both methods from now on.


    Author: Arjen van Vliet (arjen.van.vliet@uniface.com)
  2. diseli said
    Lauterbach said The program was called via : INSTALL_PATH\common\bin\uniface.exe /adm=INSTALL_PATH\uniface\adm main [SETTINGS] in main.asn contains "$license_options LM_LICENSE_FILE=..." udbg.asn was found at the right place (.\uniface\adm) The Problem was, that udbg.asn also needs the [SETTINGS] "$license_options LM_LICENSE_FILE=..." Problem is solved. Norbert  
    Hi Norbert, Thanks for clarifying this. It seems that the Debugger is now checking out "additional" license features in Uniface 9.7.05 and 10.3.01. These are: > the platform feature, like e.g. UW10 (for Windows 10) > the security feature UESC In Uniface <= 9.7.04 and 10.2 the Debugger did not use any license features. I'll discuss this with the lab. And I'll update this topic once there's some news. Thanks, Daniel  

    Quick update: I've created now the BUG#31836 (Debugger checking out Windows license feature in Uniface 9.7.05/10.3.01) for this problem.


    Author: diseli (daniel.iseli@uniface.com)
  3. istiller said BTW: To check, which ASN/INI file is in access, just put an illegal statement into it like "HELLO_WORLD". If you know start UnifAce, you got an error that HELLO_WORLD is not allowed. Than you sure, that you got the right ASN-File :)  

    I never thought of doing it this (creative) way, I'm used to doing a /who in the command line box at IDF startup.


    Author: Arjen van Vliet (arjen.van.vliet@uniface.com)
  4. Arjen van Vliet said
    istiller said BTW: To check, which ASN/INI file is in access, just put an illegal statement into it like "HELLO_WORLD". If you know start UnifAce, you got an error that HELLO_WORLD is not allowed. Than you sure, that you got the right ASN-File :)  
    I never thought of doing it this (creative) way, I'm used to doing a /who in the command line box at IDF startup.  

    Hi Arjen With /who you got only the "main" ASN-file. If you do have includes by #file, you are not sure, which one will be includedLaugh Ingo


    Author: istiller (i2stiller@gmx.de)
  5. istiller said With /who you got only the "main" ASN-file. If you do have includes by #file, you are not sure, which one will be includedLaugh

    Just combine /who with /pri=64 and you'll see which ASN files are loaded.

    Non-DBMS file open: C:/Program Files (x86)/Uniface/Uniface 9.7.01/uniface/adm/usys.asn Non-DBMS file open: C:/Program Files (x86)/Uniface/Uniface 9.7.01/common/adm/usys.asn Non-DBMS file close: Non-DBMS file close: Non-DBMS file open: idf.asn Non-DBMS file open: C:/Program Files (x86)/Uniface/Uniface 9.7.01/uniface/adm/idf.asn Non-DBMS file open: C:/Program Files (x86)/Uniface/Uniface 9.7.01/common/adm/dbms.asn Non-DBMS file close: Non-DBMS file close: Non-DBMS file open: adm/dbms.asn Non-DBMS file close: Non-DBMS file open: adm/rso.asn Non-DBMS file close: Non-DBMS file close: #file includes in my idf.asn:

    #file usysadm:idf.asn #file ./adm/dbms.asn #file ./adm/rso.asn Daniel


    Author: diseli (daniel.iseli@uniface.com)
  6. No special license required. I got the same issue and I believe what resolved it was 2 things: 1 - Be sure a udbg.asn file exists in the .\uniface\adm\ folder (must also have usys:udbg.uar in the [RESOURCES] section). 2 - Your usys.asn needs to reference usys:udbg.uar also in the [RESOURCES] section. That should get you farther along if not resolve this mystery. Larry


    Author: adkinsl (adkins.larry@gmail.com)
  7. The udbg.asn should always be present in the .\uniface\adm\ folder (this file is automatically created by the installer). The Debugger has a "problem" in case the usysadm-logical is not mapped to .\uniface\adm\ (e.g. by using the /adm command line switch for the application). If the usysadm-logical does not point to .\uniface\adm\ then it usally helps to copy the udbg.asn file from .\uniface\adm\ to .\common\adm\. It should not be necessary to change the usys.asn (in .\common\adm\). It's correct that the Uniface Debugger does not require a special license (feature). But since it cannot find the udbg.asn it probably will try to access some default database path (and this will then trigger the license error), I guess. Hope this helps. Daniel


    Author: diseli (daniel.iseli@uniface.com)
  8. The program was called via : INSTALL_PATH\common\bin\uniface.exe /adm=INSTALL_PATH\uniface\adm main [SETTINGS] in main.asn contains "$license_options LM_LICENSE_FILE=..." udbg.asn was found at the right place (.\uniface\adm) The Problem was, that udbg.asn also needs the [SETTINGS] "$license_options LM_LICENSE_FILE=..." Problem is solved. Norbert


    Author: Lauterbach (norbert.lauterbach@infraserv.com)
  9. Lauterbach said The program was called via : INSTALL_PATH\common\bin\uniface.exe /adm=INSTALL_PATH\uniface\adm main [SETTINGS] in main.asn contains "$license_options LM_LICENSE_FILE=..." udbg.asn was found at the right place (.\uniface\adm) The Problem was, that udbg.asn also needs the [SETTINGS] "$license_options LM_LICENSE_FILE=..." Problem is solved. Norbert  

    Hi Norbert, Thanks for clarifying this. It seems that the Debugger is now checking out "additional" license features in Uniface 9.7.05 and 10.3.01. These are: > the platform feature, like e.g. UW10 (for Windows 10) > the security feature UESC In Uniface <= 9.7.04 and 10.2 the Debugger did not use any license features. I'll discuss this with the lab. And I'll update this topic once there's some news. Thanks, Daniel


    Author: diseli (daniel.iseli@uniface.com)
  10. Small correction, starting from 9.7.4 G202 the debugger also needs a license.
    We have created a ticket to Uniface, but they didn't find any change that is responsible for it...

    Author: Stijn Courtheyn (stijn.courtheyn@xperthis.be)
  11. Stijn Courtheyn said
    Small correction, starting from 9.7.4 G202 the debugger also needs a license.
    We have created a ticket to Uniface, but they didn't find any change that is responsible for it...  

    Thanks for your feedback. The problem you are describing is (slightly) different and is probably caused by the fact that you are not using a default setup (with usysadm pointing to \uniface\adm). I also tried to replicate the behavior you are describing with the patch G402 (and different setups), but did not succeed. But if I remember it correctly then copying the udbg.asn from \uniface\adm to \common\adm should fix this issue. So it's not entirely accurate to say that before version 9.7.05 the Debugger also needed a license. With a default installation that is just not the case (as far as I can see). With Uniface 9.7.05/10.3.01 the Debugger, however, will check out license features when using a standard installation. This is not the case with version <= 9.7.04. Hope this helps. Daniel


    Author: diseli (daniel.iseli@uniface.com)
  12. diseli said But if I remember it correctly then copying the udbg.asn from \uniface\adm to \common\adm should fix this issue.

    Hi Norbert If someone use a special licence options attribute like $LICENSE_OPTIONS=LM_LICENSE_FILE=d:\licence_uniface\license.xml it's the best to copy the ASN-File for you development environment to common\adm as UDBG.ASN Or at least, copy $LICENSE_OPTIONS into this file. And, by the way. Be sure, that USYS.INIresp UDBG.INI contains the newest widgets definitions. Else you got a big mash as debugger surface :) Ingo BTW: To check, which ASN/INI file is in access, just put an illegal statement into it like "HELLO_WORLD". If you know start UnifAce, you got an error that HELLO_WORLD is not allowed. Than you sure, that you got the right ASN-File :)


    Author: istiller (i2stiller@gmx.de)