A technical alert about using panels and a buttonstyle 4 or higher 9.5.01 and 9.6.xx

Author: ulrichmerkel@web.de (ulrich-merkel)

There is a technical alert comming from frontline last eve: For those members who do not have access to the frontline forum, here is the text of the alert. Uniface 9.5.01 and 9.6.xx: Errors or data corruption can occur when using panels and a buttonstyle 4 or higher. The problem occurs in the following situation: An operation that performs I/O on data is activated through a panel button. During the processing the mouse is moved over other panel buttons. Symptoms: Uniface may overwrite the values assigned via proc to key and other fields with the message text of a panel button. There can be write errors or strange keys and characters in records that are stored. Entered data may be lost. This problem only occurs when the [upi] section in the Uniface ini file contains a buttonstyle is 4, 5, 6, 7 or 8. Using buttonstyle 1, 2 or 3 this problem does not occur. The problem will be fixed as soon as possible. Until a fix is available we strongly suggest to only use buttonstyle 1, 2 or 3. @adrian Gosbell: as I mentioned in http://unifaceinfo.com/forum/unifaceteam/apologies-to-uli-i-was-deleting-his-postings/ in the real uniface wold, I found a couple of customers where the real uniface developer do not have access to frontline for these people, this proxi on uniface.info is the only way to be informed about technical alerts. They do not have the means to login to frontline, so a simple link does not help them at all

2 Comments

  1. Hi Uli, we are in the process of finalizing an alert mechanism for Uniface.info, so we can ensure everybody in the community is informed.


    Author: Adrian Gosbell (adrian.gosbell@synapse-i.jp)
  2. Hi Adrian, I think all the uniface.info members welcome this good news. Thank you, Uli


    Author: ulrich-merkel (ulrichmerkel@web.de)