Uniface 9.3 IDE proc code messed-up

Author: zdenek.socha@fullsys.cz (sochaz)

Hello,

from time to time, when we open new instance of Uniface9 IDE and load a component (e.g. form), the proc code is messed up. It seems, like regular proc code is interpolated with other characters. It seems to be a problem with Unicode decoding?

Unfortunatelly, we do not have 100%-sure step-by-step description of how to reproduce it. It happens from time to time. The only solution seems to be close Uniface IDE and run it once more. I want to catch at least some screenshots, but now my question is, is there anyone experiencing the same problem?

This may be related to another bug - sometimes, there are some strange characters just before every menu item (or before underlined characters - shortcuts). Many times, it is something similar to circle :-) but I have already seen other characters as well.

AFAIK, this problem is in Uniface9.3 from all the begining througout all patches already published.

Zdenek

7 Comments

  1. I occasionally get this.
    The field explorer and entry list columns are fine, but the proc editor shows entirely bogus characters. It appears that closing the IDF and restarting is the only solution.

    I can have three IDFs open, and one will exhibit the problem where the others won't.

    I use Vista, and am on the latest patch of 9.3


    Author: Iain Sharp (i.sharp@pcisystems.co.uk)
  2. So, I have just seen this and got a screen-shot. See related content (it is uploaded in media section). [[Media:2303895 thumb right]]

    Just for info, it is latest version of Uniface running on Windows Vista:

    Release:  9.3.02
    Update:   9.3.02.01 (P209 0310_2)
    Platform: WV1
    Date:     March 10, 2010


    Author: sochaz (zdenek.socha@fullsys.cz)
  3. Yup, that's exactly what I get.

    Since I can't make it repeat on demand, I haen't een tried to log it with Amsterdam yet.

    But it does indicate that it's not just me/you.


    Author: Iain Sharp (i.sharp@pcisystems.co.uk)
  4. Do you have checke you DICT Version.

    We faced a similar situation after importing a project without updating the DICT. So compile all (with old DICT) seems to mess up some internal components.

    We decided to restart the migration. And from that point we don't get any problems.

    Maybe this helps

    Best regards

    Thomas


    Author: Thomas.Young (thomas.young@young-consulting.de)
  5. I have the same trouble on Windows Server 2008 with terminal Server.

    Have you found a solution ?

    Antoine


    Author: apicaud (antoine.picaud@free.fr)
  6. The lab is investigating this problem. It seems to have a relation with the Aero theme in Vista.  Although the RTF is correctly formatted it is not picked up by the control. Fix is planned for R101, 9.4.01.

    - Jasper


    Author: Jasper (jasper.de.keijzer@compuware.com)
  7. I too have seen the proc code issue in both Uniface 9.2 and 9.3 on a Windows Vista machine. It was logged as a help call with Compuware, but as we could not reliably replicate it, the call was closed.

    I have also seen the menu bar issue (which annoyingly prevents the use of Alt-F etc.) when using a remote desktop session.

    We use urouter with exclusive uservers for IDF sessions.

    Mark


    Author: Mark Rennison (mark.rennison@tribalgroup.com)