Problems with Datetime format in MSS

Author: None (None)

 

We migrate our system from V7.2.06 to V9.4.01, everything works fine but happened we need to read an MSS table from an old application in V7.2.06.
The problem appears when Uniface V7.2.06 reads a record that was created by Version 9.4.01 where the DateTime Format include the “Ticks”.
In Uniface 7.2.06 field type DateTime (Combine Date and Time, shorthand E) is written to Data Base without “Ticks” but V9.4.01 write include the “Ticks”
There is any way to get a compatible format DateTime between the two versions?

 

3 Comments

  1. Hi Pedro,

     

    Have a look into the documentation:

    beside the shorthand "E" there are some variations available "E1", ...

    Have a look into the documenation of the database connector to see the different mappings from uniface code to database definition.

    Uli

    P.S. the old uniface versions had $datim etc. without any ticks, so they have never be filled. This has changed in V9 now.
    But does it really gives you problems in your old application? What about using LAYOUT for datim without ticks?


    Author: ulrich-merkel (ulrichmerkel@web.de)
  2. Hello Parcaya

    Since patch R111 there is a setting to work without ticks:

    $NO_TICKS

    (see bug 29074 on Frontline).

    Another solution:

    The following entry removes ticks:

    entry noticks

    params

    datetime dt1:INOUT

    endparams

    variables

    numeric n1

    endvariables

    n1=dt1[T]

    dt1=dt1 - n1 *1t

    end

     

    So you can use for example

    fdatetime.etime=$datim

    call noticks(fdatetime.etime)

     

     

    Also

    fdatetime.etime=$datim

    fdatetime.etime=fdatetime.etime-fdatetime.etime[T] * 1t

     

    works.

    Peter


    Author: PBeugel (peter.beugel@uniface.com)
  3. Thanks, it works


    Author: parcaya (parcaya@compuamerica.com.ve)