Apache Commons Collections - on Tomcat 7.0.26

Author: knut.dybendahl@gmail.com (Knut)

Hi all, There seems to be some security issues with the above version of Commons Collections. Has anybody managed to update / upgrade Commons Collections whilst staying on Tomcat 7.0.26? Or - do I need to (or more to the point - can I) download Tomcat 8.0.24 (or even use the distribution from Uniface 9.7.x) - in conjunction with Uniface 9.6.08? Or?? Any other alternatives? Regards, Knut

2 Comments

  1. Bump - any suggestions out there??


    Author: Knut (knut.dybendahl@gmail.com)
  2. Hi Knut, AFAIK the Apache Commons Collections is not included in the Tomcat installation that is shipped with Uniface. Did you add the Commons Collections to your Uniface installation or how did it end up there? And to which version of the Apache Commons Collections are you referring to? In the title you only mention Tomcat 7.0.26. Or am I missing something here? But the latest release of Apache Commons Collections (release 4.2) requires Java 7 (or later). And the Tomcat version shipped with Uniface 9.6.xx is also using Java 7. Hope this helps. Daniel


    Author: diseli (daniel.iseli@uniface.com)